刘大喵

mikrotik有效的ROSPCQ限速脚本
关键词:max-limit------我们最常用的地方,最大速度 400K burst-limit--------...
扫描右侧二维码阅读全文
04
2013/05

mikrotik有效的ROSPCQ限速脚本

关键词:
max-limit------我们最常用的地方,最大速度 400K
burst-limit--------突破速度的最大值 1200K
burst-thershold--------突破速度的阀值 360k
burst-time-------突破速度的时间值 30s
解释一下限制意义:
当客户机在30秒(burst-time)内的平均值小于突破速度阀值(burst-thershold)360K时,客户机的最大下载速率可以超过最大限速值(max-limit)400K,达到突破最大值(burst-limit)1200K,如果30秒内平均值大于360K,那客户机的最大速度只能达到400K。这样也就是当我们开网页时可以得到一个更大的速度1200K,长时间下载时速度只能得到400K,使我们的带宽可以更有效的利用
==============================================================
1.建立静态限速脚本( /system/scripts )
:for aaa from 1 to 15 do={/queue simple add name=(PC . $aaa) dst-address=(192.168.1. . $aaa) limit-at=500000/500000 max-limit=600000/600000}
(说明: 这个是建立静态限速,1 to 15 改为你内网的IP! limit-at=500000/500000 是平均网速500K,max-limit=600000/600000 是普通限速600k!在winbox的scripts name文本框中输入PC (对应name=(PC . $aaa )
 
2.建立固定脚本
/ ip firewall mangle
add chain=prerouting action=mark-packet new-packet-mark=all-mark \
passthrough=yes comment="" disabled=no
(说明: 这个是固定脚本!直接复制!)
3.建立动态限速脚本
/ queue type
add name="PCQ-up" kind=pcq pcq-rate=125000 pcq-limit=50 \
pcq-classifier=src-address pcq-total-limit=2000
add name="PCQ-down" kind=pcq pcq-rate=250000 pcq-limit=50 \
pcq-classifier=dst-address pcq-total-limit=2000
(说明:上面表示设置PCQ-up/PCQ-down动态网速为125k/250k )
4.建立动态限速策略
/ queue simple
add name="PCQ" target-addresses=192.168.1.0/28 dst-address=0.0.0.0/0 \
interface=all parent=none packet-marks=all-mark direction=both priority=1 \
queue=PCQ-up/PCQ-down limit-at=0/0 max-limit=2000000/2000000 \
total-queue=default-small disabled=yes
(说明:到这里就是建立动态限速的策略了!192.168.1.0/28 改为你IP段!max-limit=2000000/2000000 这里是你总宽带,电信给你多少就填多少!其他不用改,,因为需要转跳到上面的!
5.PCQ限速启闭开关
/ system script
add name="PCQON" source=":if \(\[ /queue sim get \[/queue sim find \
name=\"PCQ\"\] disable \]=true \) do={/queue sim enable PCQ}" \
policy=ftp,reboot,read,write,policy,test,winbox,password
add name="PCQOFF" source=":if \(\[ /queue sim get \[/queue sim find \
name=\"PCQ\"\] disable \]=false \) do={/queue sim disable PCQ}" \
policy=ftp,reboot,read,write,policy,test,winbox,password
(说明:这个是启发脚本,就是启发动态和关闭动态的脚本!直接复制!)
6.设置流量控制开关(必须在Winbox中操作)
/ tools traffic-monitor
add name="PCQON" interface=WAN traffic=received trigger=above \
threshold=1500000 on event=PCQON comment="" disabled=no
add name="PCQOFF" interface=WAN traffic=received trigger=below \
threshold=300000 on event=PCQOFF comment="" disabled=no
(说明:这个是流量监控,我有2M带宽设置是流量大于1.5M时启发。不建议改得太少。threshold=300000是少于300k时关闭动态!这个自己掌握好!多试试!)
If you think my article is useful to you, please feel free to appreciate

Leave a Comment Cancel reply

4 comments

  1. 有今生丶没来世     Windows 7 /    Google Chrome

    1. 刘大喵     Windows 10 /    FireFox
      @有今生丶没来世

      3.x版本年代的东西了~6.x应该直接用不了需要改下格式

      1. 有今生丶没来世     Windows 7 /    Google Chrome
        @刘大喵

        没事 我就是老版本的

        1. 刘大喵     Windows 10 /    FireFox
          @有今生丶没来世

          而且还是adsl小带宽年代的东西了,现在都光纤了。

联系我